GWENT: The Witcher Card Game

Select Platform

Cyberpunk 2077

Select Platform

The Witcher 3: Wild Hunt

Select Platform

Thronebreaker: The Witcher Tales

Select Platform

The Witcher

Select Platform

The Witcher 2: Assassins of Kings

Select Platform

Windows 8 / 8.1 not supported

Created 1 month ago  Updated 3 weeks ago

Cyberpunk 2077 is not compatible with Windows 8 and 8.1 as the game requires DirectX 12, which is not supported on the mentioned OS.