GWENT: The Witcher Card Game

Select Platform

Thronebreaker: The Witcher Tales

Select Platform

The Witcher 3: Wild Hunt

Select Platform

The Witcher 2: Assassins of Kings

Select Platform

The Witcher

Select Platform

The Witcher 2 System Requirements - Linux

Created 9 months ago  Updated 4 months ago

Below you will find the system requirements for The Witcher 2: Assassins of Kings Enhanced Edition for Linux.
Please note that the game is a graphics-intensive one and it's the graphics card not meeting the minimum requirements that's often responsible for performance problems with the game.

Minimum requirements:

OS: Ubuntu 12.04 LTS, Steam OS
Graphics: NVIDIA GeForce 9800 GT 512 MB (1280x720, low), Radeon graphics cards are not supported, Intel integrated graphics chipsets are not supported
Processor: Intel Core 2 Duo
RAM: 4 GB
Hard Drive: 25 GB

Recommended requirements:

OS: Ubuntu 12.04 LTS, Steam OS
Graphics: NVIDIA GeForce GT 640 1 GB (1440x900, medium)
Processor: Quad Core Intel
RAM: 4 GB
Hard Drive: 25 GB