GWENT: The Witcher Card Game

Select Platform

Cyberpunk 2077

Select Platform

The Witcher 3: Wild Hunt

Select Platform

CD PROJEKT RED

Select Platform

Thronebreaker: The Witcher Tales

Select Platform

The Witcher

Select Platform

The Witcher 2: Assassins of Kings

Select Platform

The Witcher: Enhanced Edition and The Witcher 2: Assassins of Kings Mac System Requirements Update

Created 4 months ago  Updated 4 months ago

We are happy to announce that The Witcher: Enhanced Edition and The Witcher 2: Assassins of Kings will soon have Apple silicon M1, M2, and macOS Ventura support.

However, we will be discontinuing support for OS X 10.7.5, OS X 10.8.2, macOS 10.15, and changing the new minimum macOS requirement to macOS 11.0. This is because the technology we are using, the JIT-compatible memory management and Apple's Game Controller framework, require a minimum version of macOS 11.0. These updates are necessary to provide support to Apple silicon chips.

We want to ensure that players have time to prepare for these changes. As such, we are giving a 30-day notice before we discontinue support for these specific operating systems.

To continue playing on macOS lower than 11.0, keep the old version of the game. To do it on Steam and GOG, disable automatic updates. On AppStore no action is necessary. On all platforms, if the game is uninstalled, the latest update will be the only one available to install. However, on GOG rolling back to an earlier version is possible.